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Disclaimer
The Small Business Depot. Makes no representations or warranties, express, statutory, or implied, regarding the fitness or
merchantability of this product for any purpose. Furthermore, The Small Business Depot is not liable for any damages including but
not limited to lost profits, lost savings or other incidental or consequential damages arising out of use of this product. Furthermore, any
modification to this product renders the warranty null and void.

Windows, the Windows Logo and Word for Windows are trademarks of Microsoft Corporation.
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Introduction

Welcome to Bars & Stripes for Microsoft Word. This software enables you to use
Microsoft Word and your printer to create your own bar codes for business and personal
use.

This manual, plus the on-line help facility, will show you how to create bar codes in all
types of Microsoft Word documents, including letters, labels, and envelopes. You will
learn how to determine the appearance of the bar code by setting parameters such as size,
type, orientation and other features. Once you have selected these parameters, you can -
easily generate bar codes using skills you've already learned using Word for Windows.

You will learn how to use Bars & Stripes to create quantities of bar code labels for a
variety of purposes including inventory, mailing list, etc.

To use this program, you must have a basic working knowledge of Microsoft Word.
Refer to your Word documentation for additional information.

About Bars & Stripes

Bars & Stripes for Microsoft Word Copyright © 1993, all rights reserved.

Email: support@smallbizdepot.com

URL: http:/www.barsnstripes.com

Microsoft, Word, Word for Windows, Windows, and Office are all marks of Microsoft Corporation.
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Installation

Overview

Bars & Stripes (B&S) may be purchased on-line and downloaded to your
computer, or installed from a CD.

Before you install
< Start Microsoft Word.

Note: If you are installing Bars & Stripes into MS Word OfficeXP or Office
2000, do the following.

9 From Word's HELP menu, Disable the Office Assistant feature

(You do this by right-clicking on the Office Assistant, clicking Options, and
un-checking the Use the Office Assistant checkbox.)

@ From the TOOLS menu, select MACRO > SECURITY and set the security
to LOW. (You can reset this after you've completed the installation.)

@ From the TOOLS menu, select OPTIONS > FILE LOCATIONS. Verify
that the PATH for Startup is valid and that the named folder actually exists on
your computer.

9 From the TOOLS menu, select OPTIONS > VIEW Verify that the Picture
Placeholders and the Field Codes boxes are unchecked..

See specific installation instructions for Microsoft Word 2007 and
for Office in Windows Vista on the next page.

Continue installation instructions on next page.
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Note: If you are installing Bars & Stripes into MS Word for Office 2007, do the
following.

i -h 1
!'J Home Insert Page Layout References Mailings Review View | Developer | Add-ns

: o S Record Macrao " a | Design Mode Schema [ _.-
= e N Sk ENN=

E=) 11@ Pause Recording | 21 Properties _»] Transformation
Visual Macros T ] @- E Structure . Protect Document
Basic I\ Macro Security =l Gl I8 Group 4 Expansion Packs || Document || Template
Code Contrals XML Protect Templates

9 From the DEVELOPER menu, select Macro Security and set the security to
LOW. (You can reset this after you've completed the installation.)

Note:If you don’t see a DEVELOPER selection on the toolbar, do the
following.

9 Click the round Office button, Word Options (at the bottom) and then check
the Show Developer tab check box..

S Click the round Office button, Word Options (at the bottom). Click
Advanced, scroll to the bottom and click File Locations. Verify that the
PATH for Startup is valid and that the named folder actually exists on your
computer.

& Click the round Office button, Word Options (at the bottom). Click
Advanced, scroll to the Show Document Content section. Verify that the
Picture Placeholders and the Field Codes boxes are unchecked

@ Close all Word documents and Exit the Word application.

Microsoft Vista

Note: If your computer operating system is Windows Vista, following the
additional instructions.

< Bars & Stripes needs to install files in the Microsoft Office folder.

< For Office 2007, it’s located here: C:\Program Files\Microsoft
Office\Officel2

If you cannot locate this folder, do a search for “WINWORD.EXE”
Once you’ve located the folder, right-click on the folder.
Click Properties and then Security.

Make sure you have permission to both read and write files.

0O00o0o

Make the appropriate edits to the security settings depending on how you
logged in to this computer.

Continue installation instructions on next page.
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Installing the software
< Double-click on the downloaded file (or the file on the CD-ROM) to begin the
installation.

After the welcome message, the win-zip self extractor will display the
following dialog box:

< Click Unzip

WinZip Self-Extractor - bars4wordxp.exe

T ip all files in barsdwordsp, h g
(Also make note of the Unzip to ek o sty
Fiun ins
folder for later reference) Urip to o | M{
I‘I"\Z AT ZIALE T e Browse.. Lloze
3 MlCI’OSOft WOI’d Wlll Stal’t v Qivenaite files without prompting About |
automatically and load a document ¥ yen dene g open o |
Inztall. aoc —
named /nstall.doc

(If Microsoft Word does not start, locate the install.doc file in the Unzip to
folder referenced above and open it in Word.)

< Word now displays a document with a large button (shown here)
< Double Click the large button.

9 Verify the FROM and TO paths Double Click Here to Install

< Answer the Prompts as they occur.

Bars & Stripes will be installed and a new toolbar Icon will appear on the
Microsoft Word Standard toolbar.
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Unlocking the software

When you first install Bars & Stripes, the software is not fully enabled. 1t is
initially installed in Demo (or locked) mode. In locked mode, the software will
randomly alter characters in bar codes you create. To fully enable Bars &
Stripes, the user must purchase and enter an unlock code.

o Click the Bars & Stripes icon to display the main menu.
& Click Change Setup to display the settings menu.

< Enter your 10-digit Unlock code into the text box on the lower left of this
menu.

Acquiring an Unlock Code

If you purchased a Bars & Stripes unlock code on-line, it will be emailed to the
email address you specified. If you do not receive your unlock code within a few
hours of purchase, contact technical support.

Find the Members
If you purchased a Bars & Stripes CD, you can get your  link on the
unlock code from the members log-in screen. Barsnstripes.com
2 Go to the Bars & Stripes website and click on the website

member’s link.

< You will be prompted for a username and password.

Connect to www. barsnstripes.com
=
+- A\

(i

Enter your email address
(or other username if provided)
into the User Name box.

membets

User name: | [ 4] v |

Password: | |

Remember my passwg)
Enter your password
C o ][ ] into the Password box.

Continue.
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In the resulting form, enter the following:

< Your Install Key
(see above)

<@ Your email address
3 Your name four Email:

< Your password

Your Mame:

Then Click Submit.

To verify that Bars & Stripes is unlocked

< Click the Bars & Stripes toolbar Icon.
@ Select Change Setup

9 On the Change Setup Screen, check for the presence of the unlock code text
box. Ifitis no longer displayed, your software has been successfully
unlocked.

unies JLrn e =]
[~ Make Default

—

Once you have installed and unlocked Bars & Stripes, you are ready
to make bar codes

NOTE: Bars & Stripes gets information from the Windows Registry or ini file
regarding where the Microsoft Word (winword.exe) is located. This information is
required for the program to install and execute correctly. Bars & Stripes also adds
information to the System Registry.

NOTE: Word 7 users (Office 95) may need additional Microsoft DLL’s. If you
receive the message “Can’t find specified DLL’s” when running the software, unzip
the included file Msdll.zip into your windows/system or windows/system32 folder
unless you have newer versions of the files.
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The toolbar icon

To make the bar coding easier, the Bars & Stripes installation process installs a
new icon onto Word’s “Standard” toolbar. Through this one toolbar button, all of
Bars & Stripes’ features can be accessed.

e &1V B

The Bars & Stripes toolbar icon is context-sensitive. Its operation changes to
meet the current situation. The following table shows the result of clicking on the
toolbar icon under certain conditions.

Clicking the toolbar icon m

does this ...

Opens main menu

if the context is this ...
No text is selected (highlighted)

Makes a bar code

Valid text is selected

Opens Change Setup menu

Invalid text is selected

Creates a new document and
opens main menu

No document is selected

Creates a new document and
opens main menu

A macro document is selected

Starts column bar code process

Table column is selected

Updates bar code with current
setup parameters

A bar code is selected
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To display the Bars & Stripes Main menu, click anywhere inside your Word

document, making sure that no text is highlighted, and then click on the toolbar

Icon.

Change bar Bars & StripesXP (V5.0) X
code settings —
| Change Setup... | Tip |
Make bar codes Make Sequential. .. Tip
using data from ' UseExistingData.. | T
word table / _ | |
Create New Datafile. .. T
| "
Make bar coded / _— Enwelopes & Labels.. | Tip
. Lo
labels using Search &Replace..
. -
Mail Merge i Help |
I / Cancel |
Context-

sensitive help

Bar code setup

Make sequentially
numbered bar codes

Make a new Word
table

Search for and
replace patterns
with bar codes

The first step to making bar codes is to decide what kind of bar codes you want to
make. To read more about the various types (called symbologies) of bar codes
and what they’re used for see Appendix:Symbology.

o

Make a new WORD document
@ Click the B&S Toolbar ICON

Click Change Setup on B&S main
menu

o

9 Choose Symbology. (If you're
using B&S for 1st time and just
learning, choose Code 128

@ Verify these settings, then Click
OK

Bars & StripesXP (V5.0]

T Options
HR Text DaTh
= [+ Display Text
Symbalogy CODELZE T [ Skrip Mon-Mumeric
Height 1 [ Strip Control Characters

Yiidth Auka
%Positon  |Selection
¥ Position Selection

Fant Arial

Resalution ,ui
Crierkation ,ﬁ
Justification ,ﬁ

1
B N e e

|z|a \2_'—

Ok |

Cancel

Uriits |Inches
[ Make Default

\z_|a|z|z

About |

Help
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Parameters

You can access the Parameter Setup Menu by clicking on the Change Setup button
on the main Menu.

You can change the following parameters in the parameter setup menu. See
Appendix:Parameters for a description of each parameter:

< Symbology

S Symbology specific options

@ Height and Width

= Horizontal & Vertical Note: Bar code parameters are set
Position for the active Word document

and stored as Document
< Human readable text Variables within that document.
9 Human readable text font This means that you can have
o ) different bar code parameters for

9 Text justification different documents

@ Bar code orientation

< Text resolution

< Units (inches, centimeters,

points)

Default settings-- the .INI file

Bars & Stripes keeps information in the file, BNS.INI. This file contains the current
default parameters. New documents are initialized with these default settings. That
is, the new document’s variables are preset using the BNS.INI files parameter
values. To change the default parameters, open the Change Setup menu, select the
desired parameter values, and select the “Make Default” checkbox at the bottom of
the menu. This will cause Bars & Stripes to update the BNS.INI file with the
changed settings.

Document variables

Bars & Stripes allows you to change specific variables that affect the type and
appearance of bar codes you create. These variables are contained within and stored
with the document (They are hidden from view.) Bars & Stripes will use these
document variables when it creates a bar code in that document. The user can have
multiple documents open, each with its own set of document variables. For example,
a user may be creating UPC-A bar codes in one document, and Postal bar codes in
another. When a document is given focus (selected by clicking in it) that document’s
variables govern the type and appearance of bar codes created within it.

Bars & Stripes presets new documents with default values (see Default settings--
the .INI file.)
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Bars & Stripes Help

Bars & Stripes provides a context-sensitive help facility. Clicking the help
button from any Bars & Stripes dialog box provides help content for that specific
function.

Note: The Bars & Stripes help facility will sometimes provide an alternate
methodology for using some of the features in the software. This is due to the
differing functionality in various versions of Word for Windows.

If you need additional help, your questions can be sent to:

The Small Business Depot Technical Support via any of the methods listed
below.

EMAIL: support@smallbizdepot.com

or Mail your questions to:

The Small Business Depot
836 Washington St. E.
Kalispell, MT 59901

See the Bars & Stripes web page for the latest announcements and links to other
informative sites.

http://www.barsnstripes.com
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How do I...
Make a bar code

To make a bar code, do the following:

Step 1. Using the cursor, highlight a string of characters in the Word document. These
characters will be used to create your bar code. Make sure that the characters you
select are valid for the symbology you have selected.

Step 2.Then Click the toolbar icon. J It’s that simple.

The characters you’ve highlighted will be replaced by a bar code.

1234367690
Hint: click the middle of the string of characters
you’ve entered until Word highlights the whole
string but not the CR character at the end.

Correctly highlighted 9 [RRERIYALI

This extra black space
Incorrectly highlighted < [PRENACIM — indicates you’ve

highlighted too much

NOTE: Special characters can be inserted by using Insert Symbol from Word’s
toolbar or by using the caret (") character followed by the three-digit ASCII code.

NOTE: If you have included an invalid character (a character not allowed for a
particular symbology), Bars & Stripes will display the Change Setup menu
rather than producing a bar code
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Make a sheet of bar code labels

Microsoft Word provides a useful feature (Envelopes and Labels) which allows
you to create sheets of labels for mailings and other applications. This feature
includes templates for adhesive-backed label paper from companies such as
Avery Dennison. In Office 2000 and earlier, this feature is found under the
Tools Menu. In OfficeXP, it is found under the Tools > Letters and Mailings
menu.

In Office 2007 the Mailings feature is located on the main toolbar.

By combining Bars & Stripes with the Envelopes and Labels feature in Word,
the user can make sheets of bar coded labels for a variety of applications.

To make a sheet of duplicate bar coded labels...

9 From Word’s Envelopes and Labels menu
Click the label tab
Select Make page of the same label
Click Option and select the label template you want to use
Click New Document

A new blank label template document will be displayed.
< From the Tools > Options menu

Select the View menu by clicking the View tab
Under print and web layout options, check the text boundaries checkbox

< Starting in the top left box, 5

enter the content (text and

YW T (WA
graphics) for your label. > i s roud

1

Include the string of W0 e 0 AN
1rJ/4\54..: 'l(j:‘.H.lJ' 'l!;l:‘.ﬂ.n"

characters you will convert to

a bar code

@ Highlight the characters for
your bar code and click the

toolbar icon. Note: You may have to change your bar

code height parameter to fit your bar

S Use Word’s formatting features code on the chosen label template.

t ke the label look lik t.
0 thake the fabel look Hke you wan Note: If the bar code you make is too

long for the chosen label template, it may
be truncated and un-readable by your
scanner. Choose a larger label, a more
compact symbology, or fewer characters.

S When your design is complete,
copy and paste it into the
remaining boxes.
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Make sequentially numbered bar codes

Bars & Stripes can generate sequentially numbered bar codes quickly and easily.
These sequential bar codes can be used to create bar code labels using Word’s
mail merge feature, described in the next section.

To make sequentially numbered bar codes ...
o Select the Make Sequential button in Bars & Stripes’ Main Menu.
< Enter data into the appropriate fields as defined below.
< Save the bar codes. Enter the name of the file, or Browse to desired file.
The resulting bar code document contains a Word table with one column.

< You can merge this column onto any other Word Table with same number
of Rows. Select Merge to perform this operation.

Starting Value

This entry represents the value that will be used for the first bar code, plus the
addition of any prefix and postfix characters (see below). Leading zeros are retained
and added to each subsequent bar code (i.e. "0001, 0002, 0003 etc.).

The length of the string will remain the same as long as the new value can be
represented by the same number of digits (i.e. "0008, 0009, 0010, 0011, etc.). and
("9998", 9999, 10000, 10001, etc.)

Increment Value

This entry represents the value that will be added to the preceding value to create
each subsequent bar code value. For example, an increment value of 3 would
produce the sequence 010003, 010006, 010009, etc.

Hint: An increment of zero (0) would produce duplicate bar code values.

Quantity

This entry represents the total number of different bar code values to produce, not
counting duplicates (see below).

Duplicates

This entry represents the number of duplicates of each bar code to produce. For
example, an increment of 3 and a duplicate of 1 would produce the following
sequence: 01001, 01001, 01004, 01004, 01007, 01007, etc. The default value is 0.

Prefix and Postfix

The characters to be appended to the "front" and "end" of each sequential value. For
example, a Prefix value of "AA" and a Postfix value of "BB" would produce the
following sequence: AAOOO1BB, AA0002BB, AA0O003BB, etc.
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Make bar codes using table data

Frequently, the bar code labels you need are not all the same. By using Bars &
Stripes and Word’s Mail Merge capability, you can generate copious quantities of
bar code labels using data from a Word table.

Creating a Word Table

There are several methods you can use to create a Word table:

@ The Toolbar table icon E
9 The Create new Datafile option on Bars & Stripes Main Menu

9 The Convert Text to table option under Word’s Table > Convert menu

Whichever method you choose, you can generate bar codes using Word table data
by simply highlighting a table column and clicking the Bars & Stripes Icon.

First row contains
column names

Part Numher Price | Description

E17-003 3.95 | Blue widget holder

97-1521 749 | Large thingamabob

K21-400 iy o Thingy witha hole

T76-1210 19:  -hamacalit

Highlight the column you

Make sure the column contains wish to bar code. Click the
only characters allowed by the B&S toolbar icon

symbology requirements. No
empty cells are allowed.

Earcodes

H Part Number §) Price | Description

1 Iiz3456!l7go12 395 | Blue widget holder
H 97-1521 12.4% | Large thingamabaob

« N3a734llg7545" K21-400 t 2.8% | Thingy with a hele
H — T76-1210 1.97 | whatchamacalit

= g704'56723

1 76503745612 H Bars & Stripes will generate a column of bar

codes matching the highlighted table column.

By selecting the Merge option you can combine the bar code single column table
with the original source data table. Save this new merged table before proceeding.
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Making bar code labels with Mail Merge

You can use Microsoft Word’s mail merge feature to make bar code labels by
creating a table with bar codes as shown in the previous section.

Barcodes Part Number | SKU Price | Description
K17-003 23456789012 3.95 | Blue widget holder

1 J4567 78912 “

—HII!"II"”"“"W"'“ 97-1521 67294566753 | 1249 | Large thingamabob
& 8389749054
—Hlluﬂllllmlu'"mm,l Ez1-400 56734745784 | 2.89 | Thingy with a hole
= N6 TH 67867

T76-1210 6TE56TES645 1.97 | whatchamacalit

= 665768783

Figure 1 Merged source and bar code tables

NOTE: The mail merge feature in Microsoft Word differs in each version of Word.
Most Word versions employ a Mail Merge Wizard to assist you. The following is one
method of accomplishing a successful mail merge. Consult your Word documentation
and help facility to learn more about Mail Merge.

HINT: The Bars & Stripes help facility provides a different method.

@ From View menu, choose Toolbars > Mail Merge

[y Fj D El | Insert Word Field = | 5.7 %] E\i}::'m 3]

Create a new blank document

Click the Main Document Setup toolbar icon

Click Labels, then OK

Select a label template from the scroll box, then OK
From the Tools > Options menu, choose the View tab
Check the M Text Boundaries checkbox

Click the Open Data Source toolbar icon

Select the file with the merged table created in the previous section

O 0O 0O VOO0 OVLOLVLOVLOLOL O

Use the Insert Merge Field icon to add table data to your label design

L
REC

3]

Select the View Merged Data icon to check your labels appearance.

Propagate Label copies the finished design to the rest of the template

Click Merge to New document to produce finished labels
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Replace patterns with bar codes

Bars & Stripes provides a Search & Replace feature which searches your Word
document for strings of characters which match a specified pattern and replaces
that text with its bar code. You can search for text, numbers, and even special
characters like tab and enter.

i, L)
iy

Search my
document for a
specific pattern
and replace each
occurrence with
a bar code of
that match.

This features works similarly to the traditional search and replace of most word
processing software applications with one very big exception. The text that
matches the search is replaced not with replacement text, but with a bar code.
The bar code value is the matching text.

To Start, click the Search & Replace option in Bars & Stripes Main Men
On the Search & Replace dialog box enter the search criteria into the Find What box
Use the Special Codes drop box to add special characters to your search criteria

For example, the following search criteria would find every character string in your
document beginning with the letter A followed by 3 letters (A-Z) followed by 3 digits
(0-9) followed by the letter Z.

A/\$/\$/\$/\#/\#/\#Z

These search criteria would bar code matching character strings within your
document. For example:

AQWE123Z PR L
AQWE123

anskasez — —, INNHUALRAHGIAA T
AHIKAS6Z

acmnzgoz - INNTAVEARITRIRITA]
LMN789Z
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Add characters from the Special

Type the text you Codes drop down list. Note: The
want to search for and Special Codes differ if the Use Start the operation
replace here Pattern Matching checkbox is =

selected

Bars & StripesXPQ.0)

. . Find What | Search & Replace
Direction
Seatch Replace With
to search - Insert |Paragraph mark. j — meraw <
¢ _Dawn Special Codes Cancel J
" Up — X I
Help \
oAl ™ Match Case
Strip First/Last Character I Find Whole ‘Words Only
™ Mo ™ Use Pattern Matching
" yes I~ 5o nds Like Choose the bar code

symbology and parameters

l

Finding text to bar code is
easier if you add unique

start and stop characters to Other Options
your document text. Bars Match case — match only if Case is the same.

& Stripes will strip these
extra characters before bar

coding. Use Pattern Matching — See table below

Find whole words only — do not match partial words

Special Codes (pattern matching option)

Match any character ? For example, typing do? Finds "dot," "doodle," and "seldom."

Question (?) A2 For example, typing Where ~? Finds "Where?"

White space W Any number and combination of spaces; non-breaking spaces; tab, end-of-line, and
end-of-cell characters; and paragraph, section, and manually inserted page break
marks

Tab character "t Must be lowercase.

Paragraph mark p Must be lowercase.

End-of-line character n Must be lowercase.

Page break d Finds page breaks inserted by pressing CTRL + ENTER. (Lower case).

Section break ~d Must be lowercase.

Duplicates search text m Not allowed in this application.

Clipboard contents e Not allowed in this application.

Non-breaking space As Must be lowercase.

Optional hyphen A= If you specify search text without optional hyphens, Word finds all matching text,

including text containing optional hyphens. However, if you specify optional
hyphens in the search text, Word finds only words having optional hyphens in the
same position. For example, typing type”-writer finds only "type-writer"

Non-breaking hyphen () A~

Caret character () AN

ASCII character “nnn  Number is a decimal and replaces it with the ASCII character.
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Appendices
Symbologies

There are many bar code symbologies. Some common ones are the postal bar
code used for mail routing, the Universal Product Codes used in the retail trades,
MSI bar codes used in grocery stores, and the Code 3-0f-9 symbology often used
for data tracking and inventory. From the Parameter Setup Menu, click on the
down arrow next to the Symbology List Box and highlight the desired selection.

Codabar

The Codabar symbology is the oldest symbology, and is used for shipping/receiving
(Federal Express), publication control and distribution (libraries), as well as for
controlling government supplies.

This symbology allows the encoding of strings of up to 16 digits, 10 numeric digits
(0 through 9) and 6 special non alpha characters ("+" (plus), "-" (minus), "$"
(dollar sign), "/" (slash), ":" (colon), and "." (Point)). There are also 4 start/stop
code choices possible when using the Codabar symbology. These characters (A, B,
C, or D) must be included at the beginning or ending of a string. Using start/stop
characters gives Codabar additional coding ability due to the variable character
combinations possible. Bars & Stripes will optionally supply these start/stop
characters for you.

Code 128

Code 128, so called because it can encode all 128 ASCII characters, is the preferred
symbology for many bar code applications. It also is considered the most easily read
bar code with the highest message integrity. Bars & Stripes produces type B Code
128 bar codes. Function codes 1, 2, 3 and 4 are created by inserting character codes
(ASCII) 129, 130, 131, and 132.

HINT: Use “Insert Symbol” on Word’s toolbar.

Code 3 of 9

One of the most widely used symbologies, Code 39, can encode messages using
capitalized alpha characters, numbers 0 through 9, and seven special characters. It
has a flexible, variable-length format. Code 39 is used by the Department of Defense
and by the automotive industry, among others. Its main drawback is that it takes up a
lot of label space, sometimes causing problems when there is a lot of data to be
encoded.

Code 3 of 9 Extended

This mode extends the symbology such that it can encode the full 128 code
ASCII character set.

Code 93

Code 93, like Code 128, uses the full set of ASCII characters and is used in data
collection processes.
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EAN-13

International Article Numbering Association (EAN International) Code is the
international version of the UPC. It contains two digits more than the UPC, requiring
a total of 13 printed characters.

EAN-8
This symbology is a shortened version of EAN-13. It consists of seven characters
and an automatically inserted check digit.

Interleaved 2 of 5

Interleaved 2 of 5 is an all numeric symbology. This symbology creates highly
compressed strings of digits and for this reason is ideal for applications with narrow
space available for bar code placement such as on shipping cartons or narrow labels.
The encoded data must contain an even number of characters. Interleaved 2/5 has a
coding weakness that sometimes causes it to create false short messages within a
long message. To help prevent this, you should use it only as a fixed-length
symbology in any one application, so that label length can be checked for accuracy.

MSI

An old, infrequently used symbology, MSI is still used widely in the retail foods
industry. This symbology encodes numeric data only, in strings of between 2 and 13
digits. One or two check digits are supplied by calculating either Mod 10 or Mod 11
values from the digits.

Postal

Postal, or Postnet, is used for postal service processing. This symbology encodes
strings of numbers (zip codes) 5, 9 or 11 digits long in the symbology recognized
by Postal-code readers. This bar code is usually placed on the bottom right of letters
and mailing labels. (See Delivery Point Bar codes)

UPC-A

UPC stands for Universal Product Code. This code is typically used to record point
of sale transactions for consumer goods throughout the grocery industry.

UPC-A format requires an 11 digit string. The first digit is the classifications
number and the following 10 digits are product identifiers. Typically, the first 5
(five) digits are assigned by request by the Uniform Code Council. The remaining 6
(six) digits are assigned by the user.

UPC-E

This symbology is a shortened version of UPC. With only six numeric characters, it
is used mainly for retail items so small that regular UPC labels cannot fit. The sixth
digit must be between 5 and 9 inclusive. The check digit is calculated automatically
and encoded in a scheme referred to as "Variable Parity". The Check digit is
displayed in human readable form as the seventh digit. A leading zero digit is
affixed to the right of the bar code, outside the guard bars.
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Parameters

Bars & Stripes lets you control the appearance of your bar code. These controls
are found on the Change Setup dialog box. To access the Change Setup dialog
box, click the Bars & Stripes toolbar icon. Then Click the Change Setup menu
option.

\
Bar density
User may
specify density Height
of bar and space may be
elements. . T~ specified in
il] inches,
1123486543218 )  contimeters
\ \ or points.
Font |
User may select
display text font Check
from list Width character
Width can be specified or Automatically
automatically sized for best calculated by
scanning. Bars & Stripes
Height

The bar code height should simply be large enough for the scanner to read it easily.
To change the height from the default value (1"), click the Down or Up buttons to
the right of the height box, or type a value directly into the Height Box.

If you select the Postal symbology, Bars & Stripes will automatically size the bar
codes according to Postal Service regulations, ignoring any settings in this field.

TIP: Height includes any text displayed beneath the bar code

Width

Bars & Stripes will automatically compute the length based upon the amount of
data you are encoding, or you can specify the absolute width of the entire bar code
(in inches, centimeters or points), or you can specify the individual element width
(each bar or space is one to four elements wide).

CAUTION: It is highly recommended that you always use the Auto setting.
This will result in easier to scan bar codes.

* Automatic width computation

To have Bars & Stripes choose the optimum width, click on the button to the right of
the Width Box in the Parameter Setup Menu to display the keyword "AUTO".
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Absolute width selection

To specify the absolute width of the bar code, erase the text that appears in the Width
Box of the Parameter Setup Menu, and enter the width you desire.
NOTE: Make sure that the value agrees with the Units selection in the Units Box.

Bar code density selection

To size the width of the bar code by specifying the bar code density, click on the
button to the right of the Width Box in the Parameter Setup Menu to display the
keyword "Bars =". Following the "=", enter a number which expresses the number of
bar elements per Unit (inch, centimeter or point).

NOTE, each black bar or white space in the bar code can consist of between 1 to 4
bar elements.

Examples
Width Units Result
Bars =70 Inches 70 bar elements per inch
Bars = 28 Centimeters 28 bar elements per centimeter
Bars = 0.5 Points 0.5 bar elements per point
If you choose to specify the individual element width, the total width
of the bar code will depend on the amount of data encoded

Horizontal Position and Vertical Position
The measurements for positioning the bar code are automatically calculated from the

top and

left of the document in the unit of measurement specified (Inches,

Centimeters, or Points) or in the location specified by the "keyword" selected by
clicking on the button to the right of the X Position (Horizontal) and Y Position
(Vertical) boxes.

X Pos: Left — _ X Pos: Right
Y Pos: Top - - |l|-'?-’~‘\ Y Pos: Top
I i \ X Pos: Center
X Pos: Selection K Y Pos: Top
Y Pos: Selection o e i
\.\‘\ X Pos: Right
\Y Pos: Center
X Pos: Left
Y Pos: Center X Pos: Center
" [\ S Y Pos: Center
1
X Pos: Left \ X Pos: Right
Y Pos: Bottom X Pos: Center ‘ Y Pos: Bottom

Y Pos: Bottom
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The keyword Selection means that the bar code will be positioned wherever the
highlighted text was. You can also adjust the position of the bar code by combining
a "Keyword" with a numeric value. For example, Selection + 1.5 would position the
bar code 1.5 units from the selected text.

Human Readable Text

This field, located in the bar code Parameter Setup Menu, allows you to determine
what text will be displayed with your bar code (if you selected Display Text in the
Options field). The default selection, DATA, will display the highlighted text (the
characters you wish to be converted into a bar code).

Bars & Stripes will replace the key word DATA with the characters to be
converted. You may erase the default selection and enter any other combination of
characters, or you may combine the key word DATA with other text. For example, if
you highlight the string "12345", and you've entered the string "abc DATA efg" in
the text box, the resultant bar code text will be "abc 12345 efg"

Human Readable Text Font

In the Parameter Setup Menu's Font Options Box, click on the down arrow to see a
list of fonts in which text may be displayed. Highlight your selection. The font
selected will not affect the appearance of the bar code above the text.

Justification

The displayed text may be CENTERED beneath the bar code, aligned with the
RIGHT edge of the bar code, or aligned with the LEFT edge of the bar code. Click
on the button to the right of the Justification Box until your selection is displayed.

Orientation

There are four possible orientations for your bar code. Click on the button to the
right of the Orientation Box in the Parameter Setup Menu to view your selection.

GFEZL

12345

12345
GFELL

0 Degrees 90 Degrees 180 Degrees 270 Degrees
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Resolution

The resolution parameter affects the appearance of the text displayed beneath the
bar code. It does not affect how well a scanner can read the bar code. If you plan to
enlarge the bar code, you should select a higher resolution. In the Parameter Setup
Menu, click on the button to the right of the Resolution Box to view your selection.

NOTE: bar codes generated at a higher resolution use more of your computer's
memory and take longer to print

Bars & Stripes determines your systems’ resolution by interrogating the
Windows™ operating system. On some systems, however, this can not be done.
Bars & Stripes will use instead the value stored in the file BNS.INI. In this case,
you may be able to affect the quality of text by editing the dpi setting in the BNS.INI
file. Try a value in the range of 72 to 120.

Units

You must specify whether your bar code will be measured in inches, points or
centimeters . The default is inches. To change the units to centimeters, or points,
click on the button to the right of the Units Box to view your selection.

Note: Make sure the values you have selected for bar code height, width, X Position

and Y Position are expressed in the selected units.
(See Units Conversion Formulae.)
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Symbology Specific Options

The Parameter Setup Menu allows you to select a number of options which affect
the various bar code symbologies. Only those options appropriate for the bar code
symbology currently selected will be available for selection.. You may select as
many options from this field as you want. (See below for choices.)

Click on each option you want to select. If a feature is already selected, you may
click on it to unselect it.

Display Text
If you select this option the bar code data will be displayed in a line of text beneath
the bar code. (Depending on orientation)

Strip Non-Numeric

If you select this option, non-numeric characters in the text will be ignored

Strip Control Characters

If you select this option, any control characters (such as carriage return or Tab) in
the highlighted text will be ignored.

Add Start/Stop (Codabar Only)

If you select this option, the required start and stop characters will be added to the
beginning and end of the highlighted text.

Hide Start/Stop (Codabar Only)

Selecting this option hides the start and stop characters of the Codabar string in the
text beneath the bar code. If text is not selected, this feature does nothing.

Full ASCII Mode (Code 3 of 9 Only)

If you select this option, Bars & Stripes will use Code 3 of 9's alternate Full ASCII
mode, allowing the full ASCII character set to be used.

Code 3 of 9 Checksum (Code 3 of 9 Only)

If you select this option, an optional checksum digit will be calculated and encoded
in the Code 39 data string

UPC Checksum (Code UPC-A and UPC-E Only)

If you select this option, the UPC check digit will be displayed to the right of the bar
code. If display text is not selected, this feature does nothing.

2 Check Digits (MSI Only)

If you select this option, two check digits will be display instead of one.

Mod 11 Check digit (MSI Only)

If you select this option, the second check digit will be calculated using the modulo
11 method. The default is modulo 10.
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Delivery Point Bar Codes

The US Postal Service now requires that you append Delivery Point Bar codes
(DPBC) digits to Zip + 4 postal bar codes to receive postage discounts. These
digits are calculated by examining the primary street address. Bars & Stripes will
now automatically calculate DPBC digits when you process your mailing list with
Word 6 for Windows.

When you choose the “Use Existing Datafile” option from the main menu, and
you have selected the Postal bar code symbology, Bars & Stripes will calculate
the DPBC digits automatically. Bars & Stripes will prompt you for the name of
your datafile field which contains the primary street address. This field is usually
named something like “Address” or “Street”.

The primary street address consists of some combination of the following
elements:

Street name and number
PO Box and number
Rural Route and number
APO, FPO

As Bars & Stripes processes the datafile, it will calculate DPBC digits based
upon the information contained in the primary address field. These digits will be
encoded as bar codes and appended to Zip + 4 zip bar codes. DPBC digits are not
added to 5 digit zip codes.

A check digit is added to Zip + 4 + DPBC bar codes to complete the process.\

NOTE: Bars & Stripes is not CASS certified
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Managing Resources

Microsoft Word uses up its' resources as it performs various operations. Saving
and closing your work periodically can restore these resources. Bars & Stripes
can perform these operations for you, automatically. This will enable you to
produce many more bar codes in one operation.

Save Every

The Resource Management dialog box allows you to specify how often to save,
close, and reopen the bar code document being created. The default is 300, meaning
Bars & Stripes will save, close, and reopen the document every 300 bar codes. If
the number entered is too large, Word may run out of resources and terminate the
program. It is recommended that this number be no greater than 500.

Bars & StripesAP (¥5.0)

‘Word depletes Swskems Resources while creating bar codes,
Saving periodically helps replenshes those resources,

Bars & Stripes will do this automatically,

Save every m Barcodes,

|g:'|,smaIII:uizdepu:nt'l,I:uarsnstripes'l,dnwnlnad'l,BNST

Save File Mame

[ Increment File Extension

(0] 4 | Cancel Help

Increment Extension

Bars & Stripes can also increment the file extension each time the above process
occurs. This allows you to break a single large job into many smaller bar code
documents. For example: If you are creating 2000 bar codes, you can set the Save
Every Box to 500, and check the Increment Extension Checkbox. This will produce
4 files of 500 bar codes each with the extensions .000, .001, .002, and .003.
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Units Conversion

The values you enter for height, width, X Position and Y Position must be
expressed in the same units selected in the Units Box of the Parameter Setup
Menu. The following formulae can be used to manually convert values expressed
in different units.

To convert inches to points, multiply by 72.

To convert inches to centimeters, multiply by 2.54.
To convert centimeters to inches, divide by 2.54.

To convert centimeters to points, multiply by 28.35
To convert points to inches, divide by 72.

To convert points to centimeters, multiply by .00353

0O0o0o0vOLO
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Other Sources of Information

For other sources of information regarding Bars & Stripes, bar coding , or related
topics, see the following:

Websites

Software for barcode recognition in raster
www.axtel.com

images.

Barcode Applications and Electronic Data
www.katzscan.com Interchange (EDI) Consulting & Programming
Services
www.barcodetech.com Bar code scanners and POS equipment

www.uc-council.org Uniform Code Council

Bar Code Labels & Custom Personalized Labels

www.businessproductsdepot.com .
for business or personal use

Publications

Retail Bar Coding Basics - a Tutorial
This Guide is intended for those who want to put UPC bar codes on their trade
items. (https://service.altserver.com/~bars2sm/retailbarcode.htm)

Point of Sale - A beginners guide to computerized POS software
If you're thinking of investing in a computerized point of sale system, this is the
place to start. (https://service.altserver.com/~bars2sm/point_of_sale.htm)
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